Написать программу, создающую одномерный массив из 15 элементов. Значения членов массива...

0 голосов
43 просмотров

Написать программу, создающую одномерный массив из 15 элементов. Значения членов массива вводятся при выполнении программы. Программа должна находить минимальный и максимальный члены массива и их номера.


Информатика (17 баллов) | 43 просмотров
0

Это уже решали, пользуйтесь поиском. Или, как говорят, "ждите ответа.... ждите ответа..."

Дано ответов: 2
0 голосов
Правильный ответ

//Pascal ABC.NET 3.1 сборка 1256

begin
 var ar:=ReadArrInteger(15);
 writeln('Max:',ar.Max);
 writeln('Max index:',ar.IndexMax+1);
 writeln('Min:',ar.Min);
 writeln('Min index:',ar.IndexMin+1);
end.

(38.6k баллов)
0

В динамическом массиве индексы с нуля идут. А номер элемента - он порядковый и в этом случае на единицу больше.

0

Ранее считал это синонимами. Теперь буду знать.

0

Номера - это как в жизни, обычные значения, получаемые при счете. Если мы говорим, что у нас три книги, то при их описании используем фразы "первая книга", "вторая книга"... Но никогда у нас нет в разговоре книги с номером ноль или минус два.

0

А вот индексы - они да, могут быть любыми; определяет это постановка задачи и/или реализация решения.

0

Например, ничего не мешает индексу быть буквой, словом, фразой, неким числом или даже хеш-функцией.

0 голосов

Var mas: array[1..15] of integer;
      i, min, max, nMin, nMax:integer;
begin
  writeln('Введите 15 элементов массива');
  for i := 1 to 15 do
    readln(mas[i]);
    min := mas[1];
    max := mas[1];
    nMin := 1;
    nMax := 1;
  for i := 1 to 15 do
    begin
      if max < mas[i] then
        begin
          max := mas[i];
          nMax := i;
         end;
      if min > mas[i] then
        begin
          min := mas[i];
          nMin := i;
        end;
    end;
  writeln('Максимальное число и его номер ', max, '   ', nMax, ' Минимальное число и его номер ', min, '   ', nMin);
end.


(18 баллов)