Написать программу, создающую одномерный массив из 10 элементов. Значения членов массива...

0 голосов
45 просмотров

Написать программу, создающую одномерный массив из 10 элементов. Значения членов массива вводятся при выполнении программы. Программа должна определять сумму поло-жительных членов массива. Помогите пож


Информатика (31 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Pascal ABC.NET 3.1 сборка 1256

begin
 var ar:=readArrInteger(10);
 writeln(ar.Where(x -> x>0).Sum);
end.

Пример ввода:
-1
2
-3
4
-5
6
-7
8
-9
0
Пример вывода:
20

(38.6k баллов)