Составить программу, которая выводит ** экран меню: 1) первое; 2) второе; 3) третье; и в...

0 голосов
145 просмотров

Составить программу, которая выводит на экран меню:

1) первое;

2) второе;

3) третье;

и в зависимости от выбранного пункта выдаёт одну из надписей: «Получите суп», «Получите картошку», «Получите компот», «Оставайтесь голодным». Написать два варианта программы: с использованием условного оператора if и с использованием переключателя.


Информатика (26 баллов) | 145 просмотров
Дано ответов: 2
0 голосов
Правильный ответ



Program Atatushka1;
uses crt;
var
  M:Integer;
begin
  writeln('***************************************');
  writeln('*    Мы рады приветствовать вас       *');
  writeln('*         в нашем ресторане           *');
  writeln('*         A T A T U S H K A           *');
  writeln('*               ! ! !                 *');
  writeln('***************************************');
  writeln();
  writeln('***************************************');
  writeln('*              М Е Н Ю :              *');
  writeln('*  1. Первое                          *');
  writeln('*  2. Второе                          *');
  writeln('*  3. Третье                          *');
  writeln('*                                     *');
  writeln('***************************************');
  writeln();
  writeln('Введите номер желаемого блюда:');
  readln(M);
  writeln();
  if m=1 then
      writeln('Получите суп')
    else
      if m=2 then
          writeln('Получите картошку')
        else
          if m=3 then
              writeln('Получите компот')
            else
              writeln('Оставайтесь голодным');
end.

Program Atatushka2;
uses crt;
var
  M:Integer;
begin
  writeln('***************************************');
  writeln('*    Мы рады приветствовать вас       *');
  writeln('*         в нашем ресторане           *');
  writeln('*         A T A T U S H K A           *');
  writeln('*               ! ! !                 *');
  writeln('***************************************');
  writeln();
  writeln('***************************************');
  writeln('*              М Е Н Ю :              *');
  writeln('*  1. Первое                          *');
  writeln('*  2. Второе                          *');
  writeln('*  3. Третье                          *');
  writeln('*                                     *');
  writeln('***************************************');
  writeln();
  writeln('Введите номер желаемого блюда:');
  readln(M);
  writeln();
  case m of
    1: writeln('Получите суп');
    2: writeln('Получите картошку');
    3: writeln('Получите компот');
    else writeln('Оставайтесь голодным');
  end;
end.

(52.6k баллов)
0 голосов

uses crt;
var m:integer;
begin
writeln('1) первое');
writeln('2) второе');
writeln('3) третье');
read(m);
if m=1 then write('получите суп');
if m=2 then write('получите картошку');
if m=3 then write('получите компот')
else write('оставайтесь голодным');
end.

 

uses crt;
var m:integer;
begin
writeln('1) первое');
writeln('2) второе');
writeln('3) третье');
read(m);
case m of
1:write('получите суп');
2:write('получите картошку');
3:write('получите компот');
else write('оставайтесь голодным');
end;
end.

(7.2k баллов)