Напишите программу в паскале , которая вводит двумерный массив целых чисел 5 ** 10...

0 голосов
46 просмотров

Напишите программу в паскале , которая вводит двумерный массив целых чисел 5 на 10 элементов случайным образом и выводит его на экран


Информатика (1.3k баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const n=5; m=10;
var 
a:array[1..n,1..m] of integer;
i,j:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
   a[i,j]:=random(100);
   write(a[i,j]:4);
  end;
  writeln;
 end;
end.

Пример (массив 4*5):
Исходный массив:
  80  22  78  64  15
  21  34  96  84  12
  55  29  45  92  73
  35  60  63   9  17

(194k баллов)