Помогите пожалуйста. Напишите программу, которая возводит введённое число в степень 10,...

0 голосов
230 просмотров

Помогите пожалуйста. Напишите программу, которая возводит введённое число в степень 10, используя только операции сложения и умножения. Что произойдёт, если ввести большое число 78?


Информатика (15 баллов) | 230 просмотров
0

Странный вопрос про 78. Все зависит от того, как программу написать. Если с целочисленными переменными традиционной длины и без анализа переполнения - получится неверный результат. Если с плавающей точкой - получится результат верный.

0

А как лучше всего сделать?

0

А это Вам решать

0

Если это тема на integer - то с целыми, если на single/double - с плавающей точкой.

0

integer,спасибо

Дан 1 ответ
0 голосов
Правильный ответ

Var
  n,p2,p8,r:integer;
begin
  Write('Введите целое число: ');
  Read(n);
  p2:=n*n;   { n^2 }
  p8:=p2*p2; { n^4 }
  p8:=p8*p8; { n^8 }
  r:=p2*p8;  { n^10 }
  Writeln(r)
end.

Контрольные решения
Введите целое число: 2
1024

Введите целое число: 5
9765625

Введите целое число: 78
605996032
(на самом деле должно быть 8335775831236199424)

(150k баллов)