Написать программу ,которая выводит ** экран таблицу умножения всех чисел(в виде квадрата...

0 голосов
96 просмотров

Написать программу ,которая выводит на экран таблицу умножения всех чисел(в виде квадрата пифагора).


Информатика (178 баллов) | 96 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Program Pifagor;
uses crt;
const n=10;
var
  x,y:integer;
begin
  writeln('********************************************************');
  writeln('*                        PIFAGOR                       *');
  writeln('*                  (таблица умножения)                 *');
  writeln('********************************************************');
  write('*    * ');
  for y:=1 to n do
    begin
      write(y:2);
      if y      else      writeln(' * ');
    end;
  writeln('********************************************************');
  for x:=1 to n do
    begin
      write('* ',x:2, ' * ');
      for y:=1 to n do
         begin
          write(x*y:2);
          if y        end;
        if x*y<100 then writeln(' * ')<br>                   else writeln('* ');
        if x<10 then writeln('+------------------------------------------------------+')<br>                else writeln('********************************************************');
    end;
end.

(52.6k баллов)
0 голосов

Паскаль

 

uses crt;
var n,m:integer;
begin
  for n:=1 to 9 do
  begin
    for m:=1 to 9 do
      write(m*n:5);
    writeln;
  end;
end.

(7.2k баллов)