Нужно сделать блок-схему и написать программу. Получить квадратную...

0 голосов
34 просмотров

Нужно сделать блок-схему и написать программу. Получить квадратную матрицу

1111

1001

1001

1111


Информатика (14 баллов) | 34 просмотров
Дан 1 ответ
0 голосов

Для ручного ввода элементов:

 

uses crt;
var a:array[1..4,1..4] of integer;
n,m:integer;
begin
  clrscr;
  writeln('vvod elementov:');
  for n:=1 to 4 do
    for m:=1 to 4 do
      read(a[n,m]);
  writeln('matrix:');
  for n:=1 to 4 do
  begin
    for m:=1 to 4 do
    write(a[n,m],' ');
    writeln;
  end;
end.


image
(7.2k баллов)