Напишите программу, которая определяет, является ли введенное число четным и больше 100.

0 голосов
141 просмотров

Напишите программу, которая определяет, является ли введенное число четным и больше 100.


Информатика (15 баллов) | 141 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var n:=ReadInteger('Введите натуральное число:');
  if n.IsEven and (n>100) then Writeln('Число четное и больше ста')
  else Writeln('Неверно, что число четное и больше ста')
end.

Тестовое решение
Введите нетуральное число: 146
Число четное и больше ста

Введите натуральное число: 38
Неверно, что число четное и больше ста

Введите натуральное число: 101
Неверно, что число четное и больше ста

(142k баллов)
0 голосов

//Скучно
//Pascal ABC.NET 3.1 сборка 1256

Var
 a:integer;
begin
readln(a);
if (a>100) and (not(odd(a))) then writeln('Да') else writeln('Нет');
end.

Пример ввода:
128
Пример вывода:
Да

(38.6k баллов)