Помогите написать программу ** Free pascale пожалуйста Известен номер группы...

0 голосов
41 просмотров

Помогите написать программу на Free pascale пожалуйста
Известен номер группы первокурсников и список студентов из этой группы, по заданной фамилии студента определить занимается ли он в данной группе и под каким номером находится в списке группы
С использованием сортировки одномерных массивов


Информатика (47 баллов) | 41 просмотров
0

Сортировка пузырьком подойдет?

Дан 1 ответ
0 голосов
Правильный ответ

Считаем, что сначала вводится количество студентов, потом список студентов (по одному в строчке), потом фамилия нужного студента

var
ss: string;
s: array [1..100] of string;
n, i, j: integer;
begin
readln(n);
for i := 1 to n do
readln(s[i]);
for i := 1 to n -1 do
for j := 1 to n - 1 do
if s[j] > s[j + 1] then
begin
ss := s[j];
s[j] := s[j + 1];
s[j + 1] := ss;
end;
readln(ss);
j := 0;
for i := 1 to n do
if s[i] = ss then
j := i;
if j = 0 then
writeln('NO')
else
writeln('YES ', j);
end.

(3.6k баллов)