«Бегущая строка». Составить программу в паскале. которая изобразит в нижней части экрана...

0 голосов
158 просмотров

«Бегущая строка». Составить программу в паскале. которая изобразит в нижней части экрана строку, «бегущую» справа налево. Строка должна менять свой цвет.


Информатика (890 баллов) | 158 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

//Pascal ABC.NET 3.1 сборка 1256

uses
  GraphABC; 

Const
 s='Sample text';//текст
 d=10;//задержка

 Var
 x:integer;
begin
randomize;
x:=windowwidth;
while x>=0 do
 begin
  textout(x,windowheight-20,s); 
 setfontcolor(rgb(random(255),random(255),random(255)));
  sleep(d);
  dec(x);
  clearwindow;
 end;
end.

(38.6k баллов)
0 голосов

Uses CRT;

Const
Delay = 200; //Задержка в миллисекундах
Line = 22; //Номер строки, на которой будет текст
Text = 'Бегущая строка'; //Текст бегущей строки

Var 
i: Integer;
s: String;

Begin
  s := Text;
  For i := 1 To 80 Do
  Begin
    GotoXY(1, Line);
    TextColor(Random(14) + 1); 
    WriteLn(s);
    s := ' ' + s;
    Sleep(Delay);
  End;
End.

(13.3k баллов)
0

А можно узнать, в какой версии языка это должно работать?

0

PascalABC

0

Для других версий вместо Sleep нужно использовать Delay

0

Pascal ABC ? А там не надо подключать библиотеку?

0

Или Crt достаточно? У меня просто нет этой версии

0

У меня тоже нет. Для работы с графическим окном достаточно CRT. А sleep вроде и в изначальных версиях pascalabc был

0

Вы правы, работает и в .NET.