написать программу, которая вводит массив из N целых чисел и выводит ** экран элементы,...

0 голосов
65 просмотров

написать программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K.


Информатика | 65 просмотров
Дан 1 ответ
0 голосов

const
  N = 10;

 

var
  a: array [1..N] of integer;
  i, K: integer;

begin
  writeln('Введите число K');
  readln(K);
  for i:= 1 to N do
  begin
    writeln('Введите целое число');
    readln(a[i]);
  end;
  writeln('Числа, кратные числу ', K, ':');
  for i:= 1 to N do
    if a[i] mod K = 0 then writeln(a[i]);
end.

(2.1k баллов)