Помогите написать программу Паскаль: Организуйте массив. Выведите на дисплей значение и индекс второго положительного элемента.
Program polog; var i:byte; a:array[1..255] of single; prox:boolean; begin randomize; prox:= true; for i:=1 to 255 do a[i]:=random(254)-127; for i:=1 to 255 do if a[i]>0 then if prox then prox:=false else begin writeln(a[i],i); exit(или close не помню); end; end.
мне написали эту программу несколько проще, но она выводит и отрицательные числа
1.Uses Crt; Var A:Array [1..10] Of Integer; I:Integer; Begin For I:=1 To 10 Do Begin Writeln('Введите элементы массива A[',I,']'); Readln(A[I]); End; Writeln(); Writeln('A[2] - Индекс массива; ', A[2], ' - Значение массива'); End.