Помогите написать программу в с ++ составить программу обработки матрицы размерности...

0 голосов
32 просмотров

Помогите написать программу в с ++


составить программу обработки матрицы размерности N*M. ВЫПОЛНИТЬ программу для N=3,M=4.Заполнение массива произвести с помощью датчика случайных чисел. в программе предусмотреть вывод исходной матрицы и полученной.
По невозрастанию значений небольших элементов строк.( упорядочить(переставить)столбцы массива)


Информатика (105 баллов) | 32 просмотров
0

"небольших"? Может, наибольших?

0

да.наибольших,извиняюсь(

0

Далее. "По невозрастанию значений небольших элементов строк.( упорядочить(переставить)столбцы массива)". Может, элементов столбцов? Или нужно упорядочить строки?

0

там вместо столбцов - строки .т9 все исправил+

Дан 1 ответ
0 голосов
Правильный ответ

//Dev-C++ 4.9.9.2

#include
#include
using namespace std;

#define n 3
#define m 4

int main(){
    srand(time(NULL));
    int ma[n][m];
    int arsub[n];
    int max=-1;
    cout<<"Matrix:"<<endl;<br>    for(int i=0;i            for(int j=0;j                    ma[i][j]=rand()%50;
                    cout<<ma[i][j]<<' ';<br>                    if(ma[i][j]>max)max=ma[i][j];}
            cout<<endl;<br>            arsub[i]=max;
            max=-1;}
    for(int i=0;i     for(int j=i+1;j                    if(arsub[j]>arsub[i]){
                     for(int z=0;z                     swap(ma[i][z],ma[j][z]);
                     swap(arsub[j],arsub[i]);}
     cout<<"Final matrix:"<<endl;<br>        for(int i=0;i            for(int j=0;j                    cout<<ma[i][j]<<' ';<br>            cout<<endl;}<br>     cin.get();
     cin.get();
  return 0;
}

(38.6k баллов)
0

ошибку выбило

0

cout<<"Matrix:"<<endl;

0

Странно. На что именно ругается?

0

вы не можете прислать эти задания документами?потому что у меня ошибками почему-то выбивает.

0

Увы, не могу. Сервис не позволяет редактировать ответы спустя 2 часа после отправки. Тут дело скорее в Вашем компиляторе, даже если я пошлю вам файлы, ничего не изменится.

0

Если я создам новые вопросы и скину вам ссылки на них вы можете туда скинуть?

0

В таком случае я смогу сбросить. Но, повторюсь, ошибка на Вашей стороне. У меня всё в норме.