Перевод времени из минут и секунд в секунды. Написать программу, которая запрашивает у...

0 голосов
22 просмотров

Перевод времени из минут и секунд в секунды. Написать программу, которая запрашивает у пользователя время в виде «минуты – секунды», после чего вычисляет полное число секунд во введенном значении и выводит результат вычисления на экран. При составлении программы учесть, что число минут во вводимом значении – неотрицательно. Учесть ситуацию с переполнением.
Примечание: Предполагается использование в задании вещественных чисел. Программа должна выявлять и корректно реагировать на другие исключительные ситуации (например, деление на ноль и ситуацию переполнения).


Информатика (35 баллов) | 22 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Pascal ABC.NET 3.1 сборка 1219

Var
 m,s,r:double;
begin
try
read(m,s);
r:=s+m*60;
writeln(r);
except
 on System.OverflowException do writeln('Переполнение');
end;
end.

Пример ввода:
32345678903456787654324657865432456786543245687654356786543
3456754365786545678976543567865435678
Пример вывода:
1.94074073420741E+60

(38.6k баллов)