Написать программу поиска элемента массива, равный заданному числу 17, используя поиск с...

0 голосов
75 просмотров

Написать программу поиска элемента массива, равный заданному числу 17, используя поиск с барьером.
Решить на PascalABC
Оформить в виде процедуры.


Информатика (98 баллов) | 75 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const n=10; 
type ar=array[1..n+1] of integer;
var 
a:ar; i,p:integer; 
procedure pr(var a:ar; p:integer; var k:integer);
begin
k:=1;
while a[k]<>p do k:=k+1;
end;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(31);
 write(a[i]:4);
 end;
writeln;
p:=17;
a[n+1]:=p;
pr(a,p,i);
if i then writeln('Значение 17 найдено, номер элемента = ',i)
 else writeln('Значения 17 в массиве нет');
end.

Пример:
Массив A:
  14   5   7  17  25  15  28   0  24   0
Значение 17 найдено, номер элемента = 4

(194k баллов)