Составить программу ** языке паскаль которая меняет местами два числа без ввода...

0 голосов
57 просмотров

Составить программу на языке паскаль которая меняет местами два числа без ввода дополнительной ячейки


Информатика (12 баллов) | 57 просмотров
Дан 1 ответ
0 голосов

A:=a+b;
b:=a-b;
a:=a-b;

var a,b:real;
procedure change(var a, b: real);
begin
a := a + b; writeln(a);  
b := a - b; writeln(b);  
a := a - b; writeln(a);
end;
begin
writeln('a, b:');  
readln(a, b);  
writeln('a=', a);  
writeln('b=', b);  
change(a, b);  
writeln('a=', a);  
writeln('b=', b);  
readln;
end.

(836 баллов)