Сложное задание по информатике: Нужно написать программу ** паскале, не используя if,...

0 голосов
20 просмотров

Сложное задание по информатике:
Нужно написать программу на паскале, не используя if, then, else, с таким результатом:
Введите число
если число четное, то вывести 10;
если нечетное, то вывести -10


Информатика (17 баллов) | 20 просмотров
0

Если задание сложное, то баллов должно быть больше!?

Дано ответов: 2
0 голосов
Правильный ответ

Var a:integer;
begin
write('a = ');
readln(a);
writeln(-20*(abs(a) mod 2)+10);
end.

Пример:
a = 28
10

(194k баллов)
0 голосов

Var
n: integer;
res: boolean;
begin
readln(n);
res:=odd(n);
case res of
true: writeln('-10');
false: writeln('10');
end;
end.

(1.8k баллов)