Помогите пожалуйста я вас очень прошу ,не могу сделать задание по информатике 6 класс

0 голосов
46 просмотров

Помогите пожалуйста я вас очень прошу ,не могу сделать задание по информатике 6 класс


image

Информатика | 46 просмотров
Дано ответов: 2
0 голосов

                            Исходные данные           Промежуточные данные          Результат

                                      X     -     Y                               X    -   Y                                          X    

                                                                                                                                            5

                                      5-25

                                      5-15

                                      5-10

                                      5-5

 

                                                                                                                                            1

                                      9-14 

                                      9-5

                                      4-5

                                      4-1

                                      3-1

                                      2-1

                                      1-1

 

                                                                                                                                            6

                                     12-90

                                    12-78

                                     12-66

                                     12-54

                                     12-42

                                     12-30

                                     12-18

                                     12-6

                                      6-6

 

 

 

 

Мы так в классе с учительнице решали!!!))))

(73 баллов)
0 голосов

что не опнятно именно? как работает блок-схема?

если в блок-схеме дело, то объясню. Это цикл While(пока). Пишу блок-схему на русском.

Начало

Ввод х, у

Пока х=у, если да то вывод Х и уход на конец.

если нет, идёт дальше условный оператор if(если).

Если x>y если да, то ячейке х присвой значение х-у, если нет, то ячейке у присвой значение у-х. Дальше программа уходит на повтор.

Объясню на примере чисел.

вводим данные х=10, у=15;

10 не равно 15, значит идём на условный оператор if 

10 < 15, ячейке У присваиваем значение 15-10

на экране 5.

на всякий могу написать программу.

Program af;

uses crt;

var x,y:integer;

begin

clrscr;

     readln(x,y;

     while x=y do begin

                                    if x>y then x:=x-y

                                     else Y:=Y-X;

       end;

writeln(x);

readln;

end.

                                                                      

                                    

 

(252 баллов)