Написать программу в паскале . вводим два числа. компьютер должен вывести квадратное...

0 голосов
70 просмотров

Написать программу в паскале . вводим два числа. компьютер должен вывести квадратное уравнение,корнями которого являются эти два числа. (использоват теорему виета)


Информатика (25 баллов) | 70 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var x1,x2,p,b:real;
begin
readln(x1,x2);{Вводим два числа}
p:=x1+x2;{Вычисляем значение коэффициента при х}
b:=x1*x2;{Вычисляем значение свободного слагаемого}
if p>0 then{Проверка на знак полученных значений и вывод уравнения, как проще сделать со знаком, увы не знаю}
begin
if b>0 then
writeln('x^2-',p,'x+',b,'=0')
else
writeln('x^2-',p,'x-',abs(b),'=0');
end
else
begin
if b>0 then
writeln('x^2+',abs(p),'x+',b,'=0')
else
writeln('x^2+',abs(p),'x-',abs(b),'=0');
end;
end.

(56.0k баллов)