Напишите программу построение светофора в паскале

0 голосов
120 просмотров

Напишите программу построение светофора в паскале


Информатика (20 баллов) | 120 просмотров
Дано ответов: 2
0 голосов

var   timeInSec:integer; // время в секундах   color, s, m, h:byte; begin   h := 4; //часы   m := 5; //минуты   s := 23; //секунды

  timeInSec := h * 3600 + m * 60 + s; //перевод времени в секунды   color := (timeInSec div 10) mod 3; {целочисленно делим на 10, чтобы узнать сколько раз светофор изменил цвет}   {потом находим остаток деления на 3(количество цветов), чтобы узнать какой сейчас   цвет}   case color of //вывод ответа     0: writeln('Горит зеленый свет'); //0 - это зеленый свет     1: writeln('Горит желтый свет'); //1 - это желтый свет     2: writeln('Горит красный свет'); //2 - это крсный свет   end; end.

(271 баллов)
0 голосов

USES GraphABC, CRT; 

VAR klavisha:char;
begin
  maximizewindow;
  rectangle(600,100,1200,1000);
  circle(900,250,100);
  circle(900,500,100);
  circle(900,750,100);
  repeat
    klavisha:=readkey;
    circle(900,250,100);
    circle(900,500,100);
    circle(900,750,100);
    if klavisha='1' then floodfill(900,250,clred);
    redraw;
    if klavisha='2' then floodfill(900,500,clyellow);
    redraw;
    if klavisha='3' then floodfill(900,750,clgreen);
    redraw;
  until 9>10;
end.

Среда разработки PascalABC, свет на светофоре переключать на 1, 2 и 3 соответственно.

(2.1k баллов)