Помогите с информатикой пожалуйста. Дано натуральное число. Верно ли, что число...

0 голосов
73 просмотров

Помогите с информатикой пожалуйста.

Дано натуральное число. Верно ли, что число принадлежит промежутку от А до В и кратно 3, 4 и 5. А и В задаются.

Нужно составить программу в , но не с условием (if...), а чтоб все решалось через циклы, где это возможно!
Может кто знает.


Информатика (21 баллов) | 73 просмотров
0

Лазарус - всего лишь графическая оболочка для конструирования форм, а язык там - Free Pascal (FPC). Этой задаче Лазарус совершенно не нужен, но прося в нем, Вы тем самым резко сужаете круг возможных отвечающих - он установлен мало у кого.

0

В этой задаче цикл совершенно не нужен, потому что проверка однократная. Так что тут как раз if надо.

0

Ну может знаешь может где нибудь применить циклы можно?

0

Вы прямо как Василий Иванович Чапаев в анекдоте про ракеты и сёдла.

0

Цикл можно применить в принципе через WEND!

0

но так я еще не делал!

Дан 1 ответ
0 голосов
Правильный ответ

Бред конечно, но вариант

var
    a, b, x: integer;

begin
    readln(a, b, x);
    while (x mod (3 * 4 * 5) = 0) and (x >= a) and (x <= b) do <br>    begin
        Writeln('да');
        halt;
    end;
    
    Writeln('нет');
end.

(53.1k баллов)