Напишите программу для определения сдачи K руб. после покупки в магазине товара: перчаток...

0 голосов
128 просмотров

Напишите программу для определения сдачи K руб. после покупки в магазине товара: перчаток стоимостью A руб., портфеля стоимостью B руб., галстука стоимостью C руб. Исходная сумма, выделенная на покупку D руб. В случае нехватки денег сдача получится отрицательной.(A,B,C,D- вводятся с клавиатуры).

заранее очень благодарна!!


Информатика (134 баллов) | 128 просмотров
0

паскаль?

Дано ответов: 2
0 голосов

Var a, b, c, d : integer;
begin
writeln('Цена перчаток: ');
readln(a);
writeln('Цена портфеля: ');
readln(b);
writeln('Цена галстука: ');
readln(c);
writeln('Внесенная сумма: ');
readln(d);
writeln('Сдача: ', d-a-b-c)
end.

(312 баллов)
0

Ниже с новыми строками:

0

var a, b, c, d : integer;
begin
writeln('Цена перчаток: ');
readln(a);
writeln('Цена портфеля: ');
readln(b);
writeln('Цена галстука: ');
readln(c);
writeln('Внесенная сумма: ');
readln(d);
writeln('Сдача: ', d-a-b-c)
end.

0

Я не виноват, что этот глупый сервис знания. ком не правильно копирует текст написанный в Pascal!!!!

0

Если вы используете двоеточие в конце строки, то не думаю что стоило использовать функцию writeln(), мне кажется лучше бы подошла write()

0

У меня стандарт.. И мне больше нравится writeln, да с таким же успехом можно использовать read вмеcто readln

0

Можете не сомневаться в моей информатике!

0

read и readln почти ничем не отличаются визуально, а вот writeln() переводит строку

0 голосов

var

a, b, c, d:real;

begin

writeln('Введите стоимость перчаток');

readln(a);

writeln('Введите стоимость портфель');

readln(b);

writeln('Введите стоимость галстука');

readln(c);

writeln('Введите сумму выделенную на покупку');

readln(d);

writeln('Сдача составляет: ', d-a-b-c);

end.

(1.0k баллов)
0

Где-то этой я уже видел..

0

Наверное у меня...

0

Лол..

0

Вот так Лол... Не парень если думаешь что я у тебя взял решение, то зря ты так думаешь. Можешь в профили у меня посмотреть, я прекрасно решаю задачи на паскаль. Просто в этой задачи решение НУ ОЧЕНЬ ЛИНЕЙНОЕ и вполне может совпадать.

0

Да, ладно.. Верю:)

0

Спасибо:) хах

0

))