Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 10%...

0 голосов
340 просмотров

Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 руб. Ниже приведен рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление стоимости покупки с учетом скидки Введите сумму покупки и нажмите -> 1200 Вам предоставляется скидка 10% Сумма покупки сучетом скидки: 1080.00 руб.


Информатика (35 баллов) | 340 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var st:real;
begin
writeln('Вычисление стоимости покупки с учетом скидки');
writeln('Введите сумму покупки и нажмите ->');
readln(st);
if st>1000
 then writeln('Вам предоставляется скидка 10%. Сумма покупки с учетом скидки: ',st-st*0.1:5:2,' руб.')
 else writeln('Скидка не предоставляется. Сумма покупки: ',st);
end.

Пример:
Вычисление стоимости покупки с учетом скидки
Введите сумму покупки и нажмите ->
1200
Вам предоставляется скидка 10%. Сумма покупки с учетом скидки: 1080.00 руб.

(194k баллов)