ПОЖАЛУЙСТА, ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ Напишите программу для решения следующей задачи....

0 голосов
203 просмотров

ПОЖАЛУЙСТА, ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ
Напишите программу для решения следующей задачи. На зачётной работе по физике ученикам 9 класса было предложено 12 задач. Зачёт можно получить, если правильно решить не менее 8 задач. Сколько учеников получило зачёт? Вычислите среднее количество правильно решённых задач учащимися, получившими зачёт. Гарантируется, что хотя бы один ученик сдал зачёт. Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых задач.


Информатика (40 баллов) | 203 просмотров
Дан 1 ответ
0 голосов

Var
 n,b,i,k,r:integer;
begin
 readln(n);
 for i:=1 to n do
  begin
   readln(b);
   if b>=8 then
     begin
     k:=k+1;
     r:=r+b;
    end;
  end;
 writeln('Количество сдавших:',k);
 writeln('Среднее значение:',r/k);
end.

(336 баллов)