Написать программу в Паскаль. Дан массив целых чисел. Найти количество пар соседних...

0 голосов
49 просмотров

Написать программу в Паскаль.

Дан массив целых чисел. Найти количество пар соседних элементов, в которых одно число четное, а другое отрицательное. Выведите также сформированный массив и все искомые пары соседних элементов.


Информатика (51 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  var b:=a.Pairwise; b.Println;
  Writeln('Найдено пар: ',
    b.Where(x->(x[0]<0) and x[1].IsEven or<br>      (x[1]<0) and x[0].IsEven).Count)<br>end.

Тестовое решение
n= 10
-37 -71 -71 -65 73 -66 -33 -85 62 -92
(-37,-71) (-71,-71) (-71,-65) (-65,73) (73,-66) (-66,-33) (-33,-85) (-85,62) (62,-92)
Найдено пар: 3

(142k баллов)