Написать программу, которая для целых чисел из диапазона [30;10] выводит ** экран...

0 голосов
77 просмотров

Написать программу, которая для целых чисел из диапазона [30;10] выводит на экран удвоенные значения этих чисел.


Информатика (123 баллов) | 77 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Program Shunn;
uses crt;
const m=30;
const n=10;
var
  i: integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  for i:=m downto n do
    writeln('Число: ',i,'  Удвоение: ',2*i);
end.

(52.6k баллов)
0 голосов

CLS

a:

INPUT n

IF n<1 OR INT(n)<>n THEN GOTO a

DIM a(n)

FOR i=1 TO n

b:

INPUT a(n)

IF INT(a(n))<>a(n) OR a(n)<10 OR a(n)>30 THEN GOTO b

NEXT i

FOR i=1 TO n

PRINT 2*a(n)

NEXT i

(271k баллов)