Напишите программу, решающую любое квадратное уравнение. Паскал

0 голосов
64 просмотров

Напишите программу, решающую любое квадратное уравнение. Паскал


Информатика (32 баллов) | 64 просмотров
0

Паскал? Хорошо, что не "паскакал"...

0

Значит любое? С комплексными корнями тоже?

0

Паскаль

Дан 1 ответ
0 голосов
Правильный ответ

Program kv_ur;
var a, b, c, d, x1,x2, x:real;
begin
read(a, b, c);
d:= sqr(b) - 4*a*c;
if d<0 then write('нет решений');<br>if d = 0 then
              begin
                 x:= -b/(2*a); write('один корень: ',x:5:2)
               end;
if d>0 then 
            begin
              x1:=(-b+sqrt(d))/(2*a);
              x2:=(-b-sqrt(d))/(2*a);
              write('два корня: ', 'x1=',x1:5:2,'x2=',x2:5:2)
            end
end.

(51.1k баллов)