составить программу в паскале! 9 класс! СРОЧНО!!! Написать программу, по длинам сторон...

0 голосов
73 просмотров

составить программу в паскале! 9 класс! СРОЧНО!!! Написать программу, по длинам сторон распознающую среди всех треугольников ABC прямоугольные. Если таких нет, то вычислить величину угла С.


Информатика (2.7k баллов) | 73 просмотров
Дан 1 ответ
0 голосов

const Radian = 57.295779513;  //Сколько градусов в одном радиане

var 

  a, b, c: real;  //Стороны, лежащие против углов A, B и C соответственно

 

begin

  writeln('Введите 3 стороны треугольника в следующем порядке: a, b, c');

  readln(a, b, c);

  if (sqr(a) = sqr(b) + sqr(c)) or (sqr(b) = sqr(a) + sqr(c)) or (sqr(c) = sqr(a) + sqr(b)) then writeln('Треугольник ABC - прямоугольный')  {Если хотя бы для одной из сторон выполняется теорема Пифагора, то данный треугольник прямоугольный}

  else writeln('Угол C равен: ', arccos((sqr(a) + sqr(b) - sqr(c)) / (2 * a * b)) * Radian, ' градусов');  {Выражаем из теоремы косинусов косинус угла C, берем arccos от него и умножаем получившееся значение на количество градусов в радиане, чтобы получить ответ в градусах}

end.

Пользоваться компилятором Pascal ABC.Net, потому что это единственный компилятор из всех известных мне, который поддерживает функцию arccos.

Если будут вопросы, спрашивай.

 

 

 

(2.1k баллов)