Цикл с параметром-Pascal.Помогите ,очень прошу. Написать программу, которая находит...

0 голосов
25 просмотров

Цикл с параметром-Pascal.Помогите ,очень прошу.
Написать программу, которая находит среднее арифметическое последних цифр всех чисел от 1 до введенного n.


Информатика (30 баллов) | 25 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    i, n, s: integer;

begin
    readln(n);
    for i := 1 to n do
        s := s + i mod 10;
    writeln(s / n);
end.

(53.1k баллов)