Напишите программу, которая находит среднее значение четных и нечетных чисел из одного...

0 голосов
52 просмотров

Напишите программу, которая находит среднее значение четных и нечетных чисел из одного файла и записывает ответ в другой файл ( из файла in.txt в out.txt) Паскаль

Пример
6 - (кол-во чисел)
1 2 3 4 5 6
Среднее значение чётных ___
Среднее значение нечётных ___


Информатика (23 баллов) | 52 просмотров
0

Непонятно, откуда взялось вот это: 6 - (кол-во чисел), 1 2 3 4 5 6

0

Ведь мы вроде читаем данные из файла in.txt?

0

Или там в первой строке количество чисел, а далее - сами числа?

0

В первой строке кол-во чисел

0

Во второй строке введенные пользователем числа

0

Это всё должна выдать программа в файле "out.txt"

0

Пользователь никаких чисел не вводит - они из файла читаются.

0

Совершенно верно. Я не верно выразился.

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var s:=ReadLines('in.txt').ToArray;
  var n:=StrToInt(s[0]);
  var a:=s[1].ToWords.Select(e->StrToInt(e)).ToArray;
  var f:=OpenWrite('out.txt');
  Writeln(f,n,' - (кол-во чисел)');
  foreach var e in a do Write(f,e,' '); Writeln(f);
  Writeln(f,'Среднее значение четных ',
    a.Where(x->x.IsEven).Average);
  Writeln(f,'Среднее значение нечетных ',
    a.Where(x->x.IsOdd).Average);
  f.Close
end.

Файлы in.txt и out.txt находятся во вложении.

Содержимое файла out.txt:
15 - (кол-во чисел)
-22 49 33 47 -10 -1 20 -18 2 21 2 -25 21 -47 -36
Среднее значение четных -8.85714285714286
Среднее значение нечетных 12.25


Скачать вложение Текст (TXT)
Скачать вложение Текст (TXT)
(142k баллов)