Помогите c С#! Напишите программу, вычисляющую факториал от 2 до 13.

0 голосов
88 просмотров

Помогите c С#! Напишите программу, вычисляющую факториал от 2 до 13.


Информатика (135 баллов) | 88 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Using System;

class Program
{
public static void Main()
{
        long f = 1;
        for (int i = 2; i <= 13; i++)<br>        {
            f = f*i;
            Console.WriteLine("{0}! = {1}", i, f);
        }
        Console.ReadKey();
}
}

Результат:
2! = 2
3! = 6
4! = 24
5! = 120
6! = 720
7! = 5040
8! = 40320
9! = 362880
10! = 3628800
11! = 39916800
12! = 479001600
13! = 
6227020800

(194k баллов)
0

Спасибо!

0

Пожалуйста.

0

Пишет: Ошибка1Требуется определение типа или пространства имен, либо признак конца файлаC:\Users\555\AppData\Local\Temporary Projects\ConsoleApplication1\Program.cs21ConsoleApplication1
Ошибка2Предложение using должно предшествовать любым другим элементам пространства имен кроме объявлений внешних псевдонимовC:\Users\555\AppData\Local\Temporary Projects\ConsoleApplication1\Program.cs31ConsoleApplication1

0

Спасибо!Все правильно!

0

:)