7 класс. Turbo Pascale Задание №1:int(-5,89) int(0,53) round(-5,8) round(5,2) frac(-17,4)...

0 голосов
108 просмотров

7 класс. Turbo Pascale

Задание №1:
int(-5,89)
int(0,53)
round(-5,8)
round(5,2)
frac(-17,4)
frac(0,32)
trunc(-17,4)
trunc(15,2)
45 div 4
15 mod 8
(489 div 10) mod 10

Задача №2:Определите значение переменной a. Определите значение переменной a в результате выполнения фрагмента программы для приведенных начальных значений a, b.

if a+b>5 then a:=a-b else a:=a*b;

а=1, в=2;

а=3, в=3;

а=4, в=2;

а=-3, в=5

Задача №3: Составьте программу. Составьте программу, определяющую, кто из двух подруг старше Маша или Саша, или они ровесники.

m – возраст Маши

s – возраст Саши (исходные переменные)

результат – выведенное на экран предложение:

Саша старше Маши (если s>m)

Маша старше Саши (если m>s)

Саша и Маша ровесники (если m=s)

Задача №4:Компьютер запрашивает число. Если число положительное, то делит его на 7, в обратном случае возводит его в квадрат.

Задача №5:Найти наибольшее число издвух чисел.

Задача №6:Найти наибольшее число из трёх чисел.

Задача №7:Найти наибольшее число из четырёх чисел.

Задача №8:Узнать, что произойдёт с ракетой. В задаче три варианта ответа - 1) ракета станет спутником Земли, 2) ракета станет спутником солнца, 3) ракета покинет солнечную систему. Если в ответе получится число меньше 7.9, то нужно написать begin, если в ответе получится число равно или больше 7.9, но меньше 11.2, то ракета станет спутником Земли, если в ответе получится число равное или больше 11.2, но меньше 16.6, то ракета станет спутником солнца, если в ответе получится число равное или больше 16.6, то ракета покинет солнечную систему.

Первая космическая скорость (7,9 км/с) – спутник Земли.

Вторая космическая скорость (11.2 км/c) – спутник солнца.

Третья космическая скорость (16.6 км/с) – покидает солнечную систему.


Информатика (7.4k баллов) | 108 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Задание №1:
int(-5,89)= -5
int(0,53)=0
round(-5,8)=-6
round(5,2)=5
frac(-17,4)=0,4
frac(0,32)=0,32
trunc(-17,4)=-17
trunc(15,2)=15
45 div 4=11
15 mod 8=7
(489 div 10) mod 10=8



Задача №2:

а=1, в=2;     a=2

а=3, в=3;    a=0

а=4, в=2;    a=2

а=-3, в=5    a=-15


Задача №3:

var m,s:integer;
begin
readln(m);
readln(s);
if s>m then writeln('Саша старше Маши')
        else if m>s then writeln('Маша старше Саши ')
              else writeln('Саша и Маша ровесники');
end.

Задача №4:

var a:real;
begin
write('Введите число: ');
readln(a);
if a>0 then a:=a/7
        else a:=a*a;
writeln(a);
end.

Задача №5:

var a,b:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
if a>b then writeln('Наибольшее число: ',a)
        else writeln('Наибольшее число: ',b);
end.

Задача №6:

var a,b,c,p:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
if a>b then if a>c then p:=a
                    else p:=c
       else if b>c then p:=b
                    else p:=c;
writeln('Наибольшее число: ',p);
end.

Задача №7:

var a,b,c,d,p:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
write('Введите четвертое число: ');
readln(d);
if a>b then if a>c then p:=a
                    else p:=c
       else if b>c then p:=b
                    else p:=c;
if pwriteln('Наибольшее число: ',p);
end.

Задача №8:

var a:real;
begin
a:=0;
while a<7.9 do<br>begin
  write('Введите скорость ракеты: ');
  readln(a);
  if (a>=7.9) and (a<11.2) then writeln('Ракета станет спутником Земли')<br>    else if (a>=11.2) and (a<16.6) then writeln('Ракета станет спутником Cолнца')<br>          else if a>=16.6 then writeln('Ракета покинет Cолнечную систему')
                          else writeln('Требуется повторный ввод скорости');
end;
end.

(1.1k баллов)