PascalABC. Заданное число либо уменьшается ** 1, либо делится пополам если оно четное....

0 голосов
28 просмотров

PascalABC. Заданное число либо уменьшается на 1, либо делится пополам если оно четное. Нужно получить 1 за наименьшее количество действий, напишите программу


Информатика (21 баллов) | 28 просмотров
Дан 1 ответ
0 голосов

Ответ на фото
Пример работы программы тоже на фото.

Приношу извинения за неудобства


image
image
(1.1k баллов)
0

Можешь написать команду, которой показывается за сколько действий было сделано число 1

0

После Writeln('введите чисисло') пиши строку: g:=0;

0

после "begin;" (перед IF) пиши строку: g:=g+1;

0

В конце, перед readln(a) пиши строку: writeln('Действий было сделано ',g);