Написать программу вычисления суммы цифр 4-значного числа

0 голосов
133 просмотров

Написать программу вычисления суммы цифр 4-значного числа


Информатика (19 баллов) | 133 просмотров
0

а ты знал что есть много языков програмирования тебе в паскале?

0

да, в паскале

Дано ответов: 2
0 голосов
Правильный ответ

Var
  n, s: integer;

begin
  readln(n);
  n := abs(n);
 
  while n > 0 do
  begin
    s := s + n mod 10;
    n := n div 10;
  end;
  writeln(s);
end.

универсальный вариант, все равно сколько значное число

(53.1k баллов)
0 голосов
// Сделал Лугачев Кирилл
// Нахождение суммы 4-ёх значного числа
program sum;
var
sm:integer; // Сумма
n:integer; // Вводимое число
begin    
write('Введите 4-ех значное число: ');
readln(n);    
sm:=(n mod 10)+(n div 10 mod 10)+(n div 100 mod 10)+n div 1000;    
writeln('Сумма 4-ёх чисел: ',sm);    
End.
(172 баллов)
0

самолюбование на высоте, или вы думаете что ваше авторство где-то засветится?