Помогите с информатикой,пожалуйстааа Нужно написать программу в Pascal ABC

0 голосов
38 просмотров

Помогите с информатикой,пожалуйстааа
Нужно написать программу в Pascal ABC


image

Информатика (2.7k баллов) | 38 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Слова отделяются друг от друга одним пробелом, знаков препинания нет.
var 
s,s1:string; l,p:integer; b:boolean;
begin
writeln('Введите строку:');
readln(s);
s1:=s+' ';
l:=pos(' ',s1);
b:=true;
while p>0 do
 begin
 delete(s1,1,p);
 p:=pos(' ',s1);
 if p>0 then b:=b and (l=p);
 end;
if b then writeln('ДЛИНА');
end.

Пример:
Введите строку:
мама мыла раму
ДЛИНА

(194k баллов)