Написать программу, которая у двух чисел с разной четностью выводит ** экран нечетное...

0 голосов
224 просмотров

Написать программу, которая у двух чисел с разной четностью выводит на экран нечетное число.(PascalABC.NET)


Информатика (49 баллов) | 224 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var a:=ReadInteger('Первое число');
  var b:=ReadInteger('Второе число');
  Write('Нечетное число: ');
  if a mod 2 <> 0 then Writeln(a) else Writeln(b)
end.

Тестовое решение
Первое число 31
Второе число 40
Нечетное число: 31

(142k баллов)
0

var

0

a,b:integer;

0

begin

0

и т.д

0

Это, быть может, Вам надо по-другому, но программа написана корректно и она работает. Можете запустить и убедиться. А как именно Вам надо - это следовало указывать в условии задания. Я же не виноват, что Вам в школе дают стиль программирования, который использовался 25 лет назад.

0

Не выносить var за пределы begin... end рекомендует сам разработчик PascalABC.NET на совем официальном сайте.

0

Вот выдержка: "Программировать в стиле старого Паскаля не рекомендуется. Программы в стиле старого Паскаля менее эффективны по скорости работы и прививают отживший стиль программирования 90-х годов."

0

"Переменные следует описывать как можно ближе к месту их первого использования. Временные переменные обязательно описывать внутри блока, чтобы не захламлять раздел описания. "

0

"Расширения PascalABC.NET , связанные с внутриблочными переменными и автоопределением типа. Минимально рекомендуемый уровень программирования на PascalABC.NET, отвечающий современным требованиям к коду"

0

Покажите это Вашему учителю.