Напишите программу которая вычисляет площадь кольца , если его толщина t см, а диаметр...

0 голосов
107 просмотров

Напишите программу которая вычисляет площадь кольца , если его толщина t см, а диаметр внутреннего круга-d см (в паскале)


Информатика (550 баллов) | 107 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
S=\pi(R^2-r^2); \ R=r+t; \\ S=\pi[(r+t)^2-r^2]=\pi(r^2+2rt+t^2-r^2)=\pi t(2r+t); \\ 2r=d \to \boxed{S=\pi t(d+t)}

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var d:=ReadReal('Внутренний диаметр кольца d=');
  var t:=ReadReal('Толщина кольца t=');
  Writeln('Площадь кольца: ',pi*t*(d+t))
end.

Тестовое решение
Внутренний диаметр кольца d= 15.6
Толщина кольца t= 4
Площадь кольца: 246.30086404144
(142k баллов)