Срочно , напишите программу Дан массив, состоящий из целых чисел. Нумерация элементов...

0 голосов
150 просмотров

Срочно , напишите программу

Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4...).

Входные данные

Сначала задано число N — количество элементов в массиве (1N100). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.

Выходные данные

Необходимо вывести все элементы массива с чётными номерами.


Информатика (301 баллов) | 150 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a:array of integer;
n,i:integer;
begin
  read(n);
  setlength(a,n);
  for i:=0 to n-1 do read(a[i]);
  writeln;
  i:=0;
  while i<=n-1 do begin<br>    write(a[i]:4);
    i:=i+2;
  end;
end.

Тестовое решение:
5
7 1 3 2 5
7   3   5

(13.9k баллов)