Написать программу проверяющую гипотезу Сиракуза для всех чисел от N до M. Значения N и M...

0 голосов
66 просмотров

Написать программу проверяющую гипотезу Сиракуза для всех чисел от N до M. Значения N и M вводятся пользователем с клавиатуры. Результатом работы программы является последовательность чисел заканчивающихся ( по гипотезе Сиракуза) единицей.


Информатика (15 баллов) | 66 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    a, b, n, i: integer;

begin
    readln(a, b);
    for i := a to b do
    begin
        n := i;
        write(n);
        while n <> 1 do
        begin
            if (n mod 2) = 0 then
                n := n div 2
            else
                n := (3 * n + 1) div 2;
            write(' -> ', n);
        end;
        writeln;
        
    end;
end.

чесно передрано с некого сайта и доработано под задачу

(53.1k баллов)