Напишите программу которая вычисляет площадь кольца , если его толщина t см, а диаметр...

0 голосов
129 просмотров

Напишите программу которая вычисляет площадь кольца , если его толщина t см, а диаметр внутреннего круга-d см (в паскале)


Информатика (550 баллов) | 129 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
t,d,S:real;
begin
write('Введите значение t=');read(t);
write('Введите значение d=');read(d);
S:=Pi/4*(sqr(d+t*2)-sqr(d));
writeln('Площадь кольца=',S:5:2);
end.

(1.7k баллов)