Помогите написать программу ** C++ Для данного числа Х найти минимальный делитель...

0 голосов
36 просмотров

Помогите написать программу на C++
Для данного числа Х найти минимальный делитель отличный от 1


Информатика (12 баллов) | 36 просмотров
Дан 1 ответ
0 голосов

#include
using namespace std;

int main()
{
int x;
cout <<"Введите число: ";<br> cin >>x;
for(int i=2; i<=x; ++i)<br> if(x%i==0)
{
cout <<"Наименьший делитель равен ";<br> cout <<i <<endl;<br> break;
}

return 0;
}


image
(1.7k баллов)