Уровень B. Напишите программу, которая сортирует массив и находит количество различных...

0 голосов
76 просмотров

Уровень B. Напишите программу, которая сортирует массив и находит количество различных чисел в нем.


Информатика (49 баллов) | 76 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var a:=ArrRandom(ReadInteger('n='),10,99);
  a.Println.Sorted.Println;
  Writeln('Количество разных чисел ',a.Distinct.Count)
end.

Тестовое решение:
n= 20
60 33 12 47 79 81 33 26 73 98 82 81 71 70 96 48 13 66 29 85
12 13 26 29 33 33 47 48 60 66 70 71 73 79 81 81 82 85 96 98
Количество разных чисел 18

(142k баллов)