Напишите программу, вычисляющую значение функции y={ -1 при х<0 y={0 при х=0 y={1 при х<0

0 голосов
60 просмотров

Напишите программу, вычисляющую значение функции
y={ -1 при х<0<br> y={0 при х=0
y={1 при х<0


Информатика (212 баллов) | 60 просмотров
0

В последней строке y=1 при x>0, потому что вариант x<0 уже указан в первой строке

Дан 1 ответ
0 голосов
Правильный ответ

Это определение стандартной неэлементарной кусочно-постоянной математической функции sgn(x) - сигнум От латинского signum - знак).
В языке Паскаль эта функция уже определена.

// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
// Также проверено в WDE: http://pascalabc.net/WDE
begin
  Writeln('y=',Sign(ReadReal('x=')))
end.

Тестовое решение
x= 4.564
y=1

(142k баллов)