Помогите с Pascal Turbo. Нужно написать программуНаберите программу вычисления суммы...

0 голосов
75 просмотров

Помогите с Pascal Turbo. Нужно написать программуНаберите программу вычисления суммы S=X+X^2+...+X^n и проверьте ее работу при различных значениях X и натурального N


Информатика (12 баллов) | 75 просмотров
Дан 1 ответ
0 голосов

Var
  s, cur: longint;
  x, n, i: integer;
begin
  write('x='); read(x);
  write('n='); read(n);
  cur := 1; s := 0;
  for i := 1 to n do begin
    cur := cur * x; 
    s := s + cur;
  end;
  writeln('sum=', s)
end.

(13.3k баллов)
0

Проверить, думаю, сам сможешь