Написать программу которая выведет ** экран все 3х значные числа, содержащие цифры 7 и 9...

0 голосов
47 просмотров

Написать программу которая выведет на экран все 3х значные числа, содержащие цифры 7 и 9 и найдет их произведение


Информатика (16 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

 

var

a:string;
i,j:integer;
check:boolean;
begin
readln (a);
for i:=1 to length(a) do
begin
if (a[i]='7') then
for j:=1 to length(a) do
if (a[j]='9') then check:=true;
end;
if (check) then writeln (a);
writeln;
end.

(666 баллов)