Решить в Pascal АBC!!! Составить программу, решающую следующую задачу: Клиент внес в банк...

0 голосов
56 просмотров

Решить в Pascal АBC!!!
Составить программу, решающую следующую задачу: Клиент внес в банк R рублей. Каждый месяц эта сумма увеличивается на W рублей. Сколько будет у клиента денег через три месяца, через полгода, через год? Ниже представлен рекомендуемый вид экрана во время работы программы:

Введите исходные данные:
Величина вклада (руб.): 10000
Ежемесячная величина дохода (руб) 165
Сумма вклада по окончании трех месяцев: 10495 руб.
Сумма вклада по окончании шести месяцев: 10990 руб.
Сумма вклада по окончании года: 11980 руб.


Информатика (36 баллов) | 56 просмотров
Дан 1 ответ
0 голосов

Код в комментарии ниже

(174 баллов)
0

program bank;

uses crt;
var bamount, bdays, bpercent, bprofit: real;

BEGIN
writeln('Введите исходные данные:');
write('Величина вклада (руб.): ');
readln(bamount);
write('Срок вклада (дней): ');
readln(bdays);
write('Процентная ставка (годовых): ');
readln(bpercent);
bprofit:=bamount/100*(bpercent*bdays/365);
writeln('Доход: ', bprofit:1:2, 'руб.');
writeln('Сумма по окончанию срока вклада: ',
(bprofit+bamount):1:2, 'руб');
readkey()
END.