Написать программу ** паскалеЕсли данное число х меньше нуля, то Z присвоить значение...

0 голосов
68 просмотров

Написать программу на паскале
Если данное число х меньше нуля, то Z присвоить значение большего из 2 чисел х и у, иначе Z присвойте значение полсуммы этих чисел.


Информатика (20 баллов) | 68 просмотров
Дан 1 ответ
0 голосов

  Program Z;

Uses Crt;

var x,y,z:real;

begin

    clrscr;

    write('Введите х: ');

    readln(x);

    write('Введите y: ');

    readln(y);

    if (x<0)  and (x>y) then z:=x;

    if (x<0)   and (x<y) then z:=y;        </p>

 

    if (x>=0) then z:=(x+y)/2;

    writeln('z=',z);

   readkey;

 

end. 

 

 

 

 

(2.4k баллов)