Помогите пожалуйста написать программу для паскаль абц, но при помощи не слишком сложных...

0 голосов
23 просмотров

Помогите пожалуйста написать программу для паскаль абц, но при помощи не слишком сложных операций. "Пусть n - натуральное число и пусть n!! означает 1*3*5*...*n для нечетного n и 2*4*...*n для четного n.
Вычислить n!!" n!! - факториал. Т.ею нужно ввести натурально число(например 5), а программа должна посчитать произведение нечетных чисел(1*3*5=15)


Информатика (15 баллов) | 23 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var n,i: integer;
p:BigInteger;
begin
  p:=1;
  write('Введите N ');readln(n);
  if n mod 2<>0 then i:=1 else i:=2;
      while i<=n do begin<br>        p:=P*i;
        i:=i+2;
      end;
    writeln(p);
end.

Тест №1
Введите N 6
48

Тест №2
Введите N 5
15





(13.9k баллов)
0

Для четных все верно; для нечетных не то выдает. Например при вводе 5 мы должны получить 15(1*3*5=15)

0

Исправил

0

Спасибо огромное))