Написать программу в Паскаль абс по теме функции. задача: найти сумму цифр трех чисел.

0 голосов
43 просмотров

Написать программу в Паскаль абс по теме функции.
задача: найти сумму цифр трех чисел.


Информатика (27 баллов) | 43 просмотров
0

Pascal ABC или PascalABC.NET ?

0

.net

0

Найти сумму цифр каждого из трех числе отдельно? Или общую?

0

Хорошо, сделаю так и так, ненужное вычеркните

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
function SoD(n:int64):integer;
begin
  Result:=0;
  while n>0 do begin
    Result+=n mod 10;
    n:=n div 10
    end
end;
    
begin
  var a:=ReadArrInteger('Введите три натуральных числа:',3);
  Write('Суммы цифр чисел: '); a.Select(x->SoD(x)).Println;
  Writeln('Общая сумма цифр всех чисел: ',a.Select(x->SoD(x)).Sum)
end.

Тестовое решение:
Введите три натуральных числа: 56325 23131 784545223
Суммы цифр чисел: 21 10 40
Общая сумма цифр всех чисел: 71

(142k баллов)
0

Или Вам нужен "школьный" вариант?

0

все верно, спасибо))))

0

Да оно-то верно, конечно))) Но может быть, "так нас не учили", а баллов Вы дали достаточно, чтобы получить и два варианта.

0

все ок)

0

Ну и славно