Пожалуйста, помогите написать программу для системы ** фото

0 голосов
49 просмотров

Пожалуйста, помогите написать программу для системы на фото


image

Информатика (818 баллов) | 49 просмотров
0

Какой еще "системы"? Это функция, имеющая кусочное определение.

0

Честно говоря, я плохо понимаю информатику, поэтому и попросила помощи

0

Определение функции, как и системы уравнений - это не информатика. Математика в чистом виде.

0

запомню на будущее

0

Любимое оправдание школьников: ссылаться на незнание одного предмета в то время, как на самом деле налицо незнание совсем иного.

0

Я вижу 2 системы в одной.

0

"Система уравнений — это условие, состоящее в одновременном выполнении нескольких уравнений относительно нескольких (или одной) переменных." Тут нет одновременного выполнения, поскольку для заданного х выполняется или одно, или второе.

0

Посему написанные выражения не образуют системы уравнений.

0

я поняла

Дан 1 ответ
0 голосов
Правильный ответ

//Pascal ABC.NET v3.1 сборка 1219

Var
 x,y:real;
begin
 readln(x);
 if x>0 then y:=power(x,4)-2*sqr(x)-6 else y:=sqr(x)-5*x+1;
 writeln(y);
end.

Пример ввода:
0
Пример вывода:
1

(38.6k баллов)
0

а разве сначала не writeln , а потом readln?

0

writeln() - вывод, readln() - ввод

0

ааа, хорошо, спасибо